1С Предприятие 7.7. Конфигурация Бухгалтерия+Торговля+Склад



         

Подключение торгового оборудования в конфигурации - часть 3


// ....

ИначеЕсли ККМ.РежимККМ=Перечисление.РежимыККМOnLine Тогда

// подключение ККМ ХХХХХХХХ в режиме OnLine

// ....

КонецЕсли ;

КонецПроцедуры

//——————————————

Процедура ПриОткрытии()

Если глФлагРасшифровки=1 Тогда

Расшифровка=глРасшифровка;

Если Расшифровка.РазмерСписка()<>0 Тогда

ККМ=Расшифровка.Получить("ККМ") ;

Если ПустЗнач(ККМ)=1 Тогда

СтатусВозврата(0) ;

Возврат;

КонецЕсли;

Если НЕ(ККМ.ТипККМ=Перечисление.ТипыККМ.ХХХХХХХХХ) Тогда

Сообщить("Передан неверный тип ККМ") ;

СтатусВозврата(0) ;

Возврат;

КонецЕсли;

Процесс=Расшифровка.Получить("Процесс") ;

Если Процесс="Подключить" Тогда

Подключить();

ИначеЕсли Процесс="ПечататьЧек" Тогда

ПечататьЧек() ;

ИначеЕсли Процесс="ЗагрузкаТоваров" Тогда

ЗагрузкаТоваров() ;

ИначеЕсли Процесс="ЗакрытиеСмены" Тогда

ЗакрытиеСмены();

Иначе

Сообщить("Передан неизвестный процесс");

КонецЕсли;

СтатусВозврата(0) ;

КонецЕсли;

КонецЕсли;

КонецПроцедуры

//——————————————

Образцы специальных обработок обслуживания ККМ можно по­смотреть в поставляемой конфигурации на примере обработок «ОбслуживаниеЭлектроника92» и «Обслуживание Omron2810».

 





Содержание  Назад  Вперед